Friday, November 30, 2007

Mac OS X v10.5 and Java 6

So, it's well documented on the web that it was expected that Apple would ship Java 6 with Mac OS X v10.5 (Leopard) and didn't. For those who have been living under a rock, they shipped Java 5, despite Java 6 existing for Windows, Linux and Solaris users for well into the "years category" now. There has been quite a lot of heated action on forums.

But the thing is that most of those people can live with Java 5 - it doesn't make a huge difference to them. It does to me - my main development machine is my MacBook, our software is written in Java, and we upgraded to Java 6 not long after it shipped. About when the Apple JDK 6 beta shipped, actually.

Anyway, I've been looking around the web for evidence that the beta (that Apple have helpfully removed from their website without replacing it with another version) runs on OS X v10.5, in the hope that I can continue working on my MacBook with the old beta. I've done the upgrade, and for those who want to know - no, you can't run the JDK 6 for OS X v10.4 beta on v10.5 - the installer won't let you install it.

So, we'll have to see next week whether we actually use any "JDK 6 only" features when I'm forced to use JDK 5, or if I'll have to "downgrade" to OS X v10.4 or even a PC with Linux.

No comments: